Forum
No internet connection
  1. Home
  2. Dashboard

Cannot fill the parameter for Data Source

By Aston Nugroho @astonix2020-08-14 04:31:23.474Z

Hi,

i want to setup dashboard in WISE-PaaS with data source from WebAccess.
But when i tried to add data source and choose WebAccess, the parameter form like HTTP, Basic Auth, Webaccess Details cannot be filled manually.

Then, when i tried to click Save, there are error seems like cannot communicate with the WebAccess.

How can i solve this issue?

Solved in post #12, click to view
  • 12 replies
  1. M
    @marc_lin2020-08-14 05:29:32.790Z

    Hi,

    Please make sure what Data Source "Type" you use is.
    If you want to get data from the source of DataHub, please choose the "DataHub-SimpleJson".
    You can see the instruction in the Level 1 course.
    The Link: https://training.wise-paas.advantech.com/en/Level-I/content/WISE-PaaS_Dashboard_Demo

    Thank you~

    1. AAston Nugroho @astonix2020-08-14 08:23:36.024Z

      Hi,

      It is "Webaccess" by default and i cannot change it.

      I installed in local PC along with WebAccess SCADA.

      1. M@marc_lin2020-08-14 08:48:57.900Z2020-08-14 08:50:35.605Z

        Please give us your whole screenshot including the dashboard URL you used to recognize the problem you occur.
        ty.

        1. AAston Nugroho @astonix2020-08-14 09:53:39.278Z

          Hi,

          this is the screenshot of the issue

    2. In reply toastonix:
      Stanley Yeh @adv.stanley2020-08-14 05:42:33.043Z

      @astonix are you using the 'local' version Dashboard that comes with WebAccess installation or the 'cloud' version Dashboard deployed into your EnSaaS space?

      1. AAston Nugroho @astonix2020-08-14 09:54:48.958Z

        I installed in local PC along with WebAccess SCADA.

        1. M@marc_lin2020-08-14 10:00:11.485Z

          Just like Stanley mention, you used the the LOCAL version Dashboard of WevAccess.
          Please refer to the training course video to operate: https://training.wise-paas.advantech.com/en/Level-I/content/WISE-PaaS_Dashboard_Demo
          Using the Dashboard of WISE-PaaS: https://dashboard-level1-eks004.sa.wise-paas.com/
          ty

          1. AAston Nugroho @astonix2020-08-14 15:47:33.672Z

            Okay, i will try it. Later i will update if there is success or not.
            Thank you

            1. Stanley Yeh @adv.stanley2020-08-17 05:07:28.785Z
              1. AAston Nugroho @astonix2020-08-26 11:36:34.667Z

                Hi All,
                I've downloaded all the training materials.
                Just curious, does every project with local WISE-PaaS need to configure node credential in Datahub in order to connect/read datasource?
                Can i just direct connect to the local webaccess tags and then "call" from WISE-PaaS?

      2. In reply toastonix:
        Stanley Yeh @adv.stanley2020-08-18 09:14:51.197Z2020-08-18 09:30:02.091Z

        @astonix I have found a document in our technical note, please refer to the PDF titled '[SE_TNE_Local WISE-PaaS Dashboard]How to installation WebAccess WISE-PaaS Dashboard Server and Postgresql' here: https://www.dropbox.com/s/3g2x8e4n59mc3yn/[SE_TNE_Local WISE-PaaS Dashboard]How to installation WebAccess WISE-PaaS Dashboard Server and Postgresql.pdf?dl=0

        Another related document is available here:
        http://advdownload.advantech.com/productfile/Downloadfile2/1-1XX30CQ/[SE_TNE_Local WISE-PaaS Dashboard]How to confirm whether WebAccess WISE-PaaS Dashboard Server is started.pdf

        Thanks.

        ReplySolution
        1. AAston Nugroho @astonix2020-08-26 11:41:42.448Z

          Hi,

          i've checked my webaccess and postgresql installation on my machine and it works well.
          Both webaccess and postgresql database are running.