Forum
No internet connection

Wise-4012 iSensing Mqtt setting

By YIN KAI OOI @ykia2020-09-13 05:52:31.308Z

Hi, I'm facing problem when connecting rabbitmq mqtt service on my Wise-4012 device. I get my rabbitmq hostname, port, username and password from my service portal.

When i using mqtt protocol, it show the error "WebSocket connection was unexpectedly aborted". Besides, i also notice that the username was exceed the length limit. So i try ws protocol.

And I got another error "Connection to host was failed".

Anyone can helped?
Solved in post #5, click to view
  • 4 replies
  1. Stanley Yeh @adv.stanley2020-09-14 02:26:18.477Z

    When finding the MQTT connection information in the secret, please be sure to use the information given under the protocol that you are using.

    From your settings screenshot, I would suggest you to change the port to 1883, and also double check username and password is correct from the "mqtt" block in the secret you are using (sample image shown above).
    Please keep the MQTT host name setting to external host in the secret (rabbitmq-001-pub.sa.wise-paas.com).

    1. Y
      In reply toykia:
      YIN KAI OOI @ykia2020-09-14 02:44:42.347Z

      I had tried many times using mqtt but the username in the settings only accept 64 characters while the username in rabbitmq secret mqtt protocol has 73 characters. So I cannot put in the username completely.

      And I think that the Wise-4012 only support MQTT over Websocket. So I try the ws protocol in rabbitmq secret but still cannot.

      1. Stanley Yeh @adv.stanley2020-09-14 03:14:55.464Z

        from our FAQ, WISE-4000 series should support MQTT (TCP without TLS), MQTT+SSL (TCP with TLS), and WS (WebSocket without TLS).
        https://support.advantech.com/support/KnowledgeBaseSRDetail_New.aspx?SR_ID=1-1UFFYTQ&Doc_Source=Knowledge+Base
        (please ignore the parts describing WISE-PaaS 3.0 management portal operation, the rest is still applicable)

        Firmware version A2.01 BXX should work given the username length, could you please check the firmware version?

        1. YYIN KAI OOI @ykia2020-09-14 03:48:46.283Z

          My firmware version is A2.00 B04.
          I have upgraded the firmware to A2.01 B01 and it works now.
          Thanks.

          ReplySolution