Forum
No internet connection
  1. Home
  2. Docker & Kubernetes

靜態網頁部屬

By janeyang @janeyang
    2020-11-04 07:02:49.905Z

    Hi.我在github下載文件並更改後.經過docker build/push, kubectl apply 後. 得到了一個link也成功顯示出網頁..不過今天想更新網頁先做了一個步驟: " kubectl delete -f k8s-config ",之後再重新佈署. 結果連帶其同樣的spacename下.所有的link都出現error.再也無法成功link網站.不知道哪裡出了問題.請問有人知道如何解決嗎??謝謝!!

    • 5 replies
    1. M
      @marc_lin
        2020-11-04 07:36:51.276Z

        Hi @janeyang,

        就如你所說,你都將config delete了當然會有問題囉。
        請你把config加回來即可。

        1. Jjaneyang @janeyang
            2020-11-04 07:59:12.980Z

            Hi. @marc_lin
            我下了命令:" kubectl apply -f k8s-config/ --namespace demo1" 不是就是加回config嗎?還是有別的呢?請解惑.謝謝!!

            1. M@marc_lin
                2020-11-04 08:30:33.804Z

                Hi, 先用 "kubectl get all" 確認你有問題的pod的狀態,是否在running.
                和用 "kubectl describe" 看Image你使用的版本是否匹配你最新的。
                確認你更新網頁的內容有更改到什麼(跟原本正常的差異)?

            2. S
              In reply tojaneyang:
              @sk_chen
                2020-11-04 08:23:00.564Z

                Hi aneyang,
                coding有改過,docker必須重新build and push 。
                k8s部署只是針對資源做更動與coding無關。
                部署參考文件:https://www.notion.so/APP-2383358d957d45d9b46a7d32a068bbb6

                1. J
                  In reply tojaneyang:
                  janeyang @janeyang
                    2020-11-04 08:27:06.047Z

                    HI.感謝各位相助....問題已經知道了..
                    原因是因為我超過Pod的最大數量了..
                    謝謝!!

                    1. Progress
                    2. J@janeyang closed this topic 2020-11-04 08:27:30.714Z.